angular-cli


Create Project with Angular 4 Release using angularcli


How do I create new project with the latest angular 4 release using angularcli with the command below
$ ng new new_project
I have the following versions installed
- #angular/cli: 1.0.0-rc.2
- node: 7.7.3
- npm: 4.4.1
You cannot create a new Angular application with the CLI that uses Angular 4 out of the box. At least, not at the moment. Only Angular 2 is supported by the CLI, at this time. I imagine that will change soon enough.
However, you can create a new application using ng new <app-name>, and then change the version of Angular it uses in the package.json. Run npm install, and it should all work. That has been my experience.
Hope this helps you out.
UPDATE:
I am mistaken! There is an option that you can pass to the ng new command that will set up the project to use ng 4.
ng new project_new --ng4
From ng --help:
--ng4 (Boolean) (Default: false) Create a project with Angular 4 in the template.
Right now this sets up the #angular section package.json as follows.
"dependencies": {
"#angular/common": ">=4.0.0-beta <5.0.0",
"#angular/compiler": ">=4.0.0-beta <5.0.0",
"#angular/core": ">=4.0.0-beta <5.0.0",
"#angular/forms": ">=4.0.0-beta <5.0.0",
"#angular/http": ">=4.0.0-beta <5.0.0",
"#angular/platform-browser": ">=4.0.0-beta <5.0.0",
"#angular/platform-browser-dynamic": ">=4.0.0-beta <5.0.0",
"#angular/router": ">=4.0.0-beta <5.0.0",
...
Just tried it, and it works.
I hope this helps you out.

Related Links

How to run Angularcli project with https
what is npm i bootstrap#next?
Angular-Cli Best way to manage notices
Puzzling angular-cli AOT error
Create Project with Angular 4 Release using angularcli
addons removed in angular-cli.json whats the replacement
angular-cli: ng serve command with config error
Augury Angular-cli When I installed the augury .Error is as follows
Teamcity for building Angular cli app
angular cli update issue on local folder
Access to -aot parameter in code
Missing peer dependencies after installing latest angular-cli: What to do?
angular-cli ng serve : Error: No errors
Getting error after Angular cli update
Does angular-cli uses rollup to do ahead-of-time compilation and adding all into one file?
Angular CLI install error

Categories

HOME
cntk
sidekiq
sass
erlang
tinyos
freepascal
reportportal
docker-swarm
terrain
gimp
contact-form-7
aruco
click
jboss-eap-7
jboss7.x
gatsby
eclipse-luna
redux-observable
jpeg2000
movies
google-api-java-client
jive
thingsboard
pdfsharp
printdocument
cep
cgal
system.data.sqlite
blackboard
devforce
roundcube
pyscripter
color-scheme
broadleaf-commerce
.net-assembly
autocompletetextview
image-compression
silverlight-3.0
agent
infusionsoft
knockout-3.0
appstore-approval
mouseclick-event
dwarf
httplib2
python-hypothesis
inject
push-diffusion
packagemaker
chessboard.js
cron-task
mix
radians
unsatisfiedlinkerror
selecteditem
dac
datainputstream
android-cursoradapter
file-diffs
site-prism
uialertview
castle-windsor-3
type-mismatch
google-hadoop
word-2013
android-search
grunt-contrib-concat
livechat
node-inspector
dalekjs
genetic-programming
wss
httpcontext
baucis
ng-hide
javascriptmvc
ienumerator
cgimageref
zend-lucene
transitive-closure-table
cgpath
usn
sunspot-rails
redirectstandardoutput
isolatedstorage
msgbox
selectonemenu
scalaxb
associative
ets
delegatecommand
boost-date-time
idictionary
plinq
inline-if
outlook-form

Resources

Mobile Apps Dev
Database Users
javascript
java
csharp
php
android
MS Developer
developer works
python
ios
c
html
jquery
RDBMS discuss
Cloud Virtualization
Database Dev&Adm
javascript
java
csharp
php
python
android
jquery
ruby
ios
html
Mobile App
Mobile App
Mobile App